Jump to content

Recommended Posts

I've got a zebco omega issue.  It has a "grinding / rough" noise and feel when reeling.  But it's smooth as silk if I take the spinner head off.  

 

I've replaced the spinner head with a new one, and the same issue.  Nothing is wobbling, bent or out of whack, and I've cleaned and re-lubed everything.

 

I've compared it to other reels of the same model, and this is definitely atypical.  

 

What could be causing this?  

Share this post


Link to post
Share on other sites

What is a "spinner head"?? You won't get much help here as most are using open face spinning reels or baitcasting reels but it sounds as if a gear tooth has been sheared off or damaged, I don't think those have bearings but I may be wrong, and at that price just get a new one.

Share this post


Link to post
Share on other sites

Send it in to Zebco. They may fix it, but I suspect they will just replace the reel.

Share this post


Link to post
Share on other sites

Sounds to me like some part of the spinner head is rubbing on the cover. Give the cover a good inspection and see if you can find any rub marks, may even be something with a line pickup pin. Also try the reel with the spinner head on and cover off, if it smooth in this manner it should be a rubbing issue with the cover.

Share this post


Link to post
Share on other sites

It does sound like your front cover needs to be replaced. Zebco woud be happy to send you a replacement.  Just give us a call.

 

1-800-588-9030

 

 

-Zebco Team

  • Like 1

Share this post


Link to post
Share on other sites

Ain't that something? Thanks for helping a BR member.

  • Like 1

Share this post


Link to post
Share on other sites

It does sound like your front cover needs to be replaced. Zebco woud be happy to send you a replacement.  Just give us a call.

 

1-800-588-9030

 

 

-Zebco Team

 

 

Well Hello Zebco Team and Welcome to BR ~

 

That's Very Cool.

 

A-Jay

  • Like 1

Share this post


Link to post
Share on other sites

Pretty cool....guess you never know who is reading these forums.

Share this post


Link to post
Share on other sites

I've got a zebco omega issue.  It has a "grinding / rough" noise and feel when reeling.  But it's smooth as silk if I take the spinner head off.  

 

I've replaced the spinner head with a new one, and the same issue.  Nothing is wobbling, bent or out of whack, and I've cleaned and re-lubed everything.

 

I've compared it to other reels of the same model, and this is definitely atypical.  

 

What could be causing this?  

 

It does sound like your front cover needs to be replaced. Zebco woud be happy to send you a replacement.  Just give us a call.

 

1-800-588-9030

 

 

-Zebco Team

 

Welcome to both of y'all!

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • fishing forum

    fishing

    fishing forum

    fishing rods

    fishing reels

    fishing

    fishing

    bass fish

    fish for bass
    fish

×