Jump to content
Dropshot_guy

Megabass vision 110 problem

Recommended Posts

I have a vision 110 and I am having problems with the "Multi-Way Moving Balancer System". One of the tungsten balls has gotten stuck in the back of the lure. Any ideas of how to get it to roll freely like it is supposed to? Thanks!

Share this post


Link to post
Share on other sites

Never had that issue.  You've probably tried this...But I'd try some light tapping/shaking to dislodge it.  You could also try leaving it in the sun for a while to heat up, may make dislodging it a little easier with the warmer plastic.  I've heard MB-USA is pretty good at dealing with issues, might try shooting them an email if you can't get it fixed to see what they can do for you. 

One other thought...Has it always been that way?  The Silent Riser and NC models have the tungsten balls fixed at either end of the bait.  

  • Like 1

Share this post


Link to post
Share on other sites

Logan S thanks for the reply. I have tried tapping it on the table and no it has not always been that way. I will try leaving it out in the sun to warm up and try again, and will also send them an email. Thanks again!!

Share this post


Link to post
Share on other sites

not sure if tungsten is magnetic but you could try a strong magnet to try and get it to move

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • fishing

    fishing forum

    fishing rods

    fishing reels

    fishing

    bass fish

    fish for bass
    fish

×