Jump to content

Recommended Posts

I don't know how to communicate this to the right person/moderator etc. so here goes.

I usually simply browse this forum and enjoy the information shared here. On the rare occasion that I want to participate in a thread or contribute in some way I can't ever simply log in. When I click on "log in" a page appears with my established user name and password that was established when setting up my account. I click on "log in" and a message appears saying my established stuff is not correct. Have to click on "forgot your password" and go to email to reset my password. I type in the same old password that I used here before (and that I use for everything else) and I gain access for one time. Next time I try to log in here I have to go through the same crap.

I don't mean to dump here but don't know how to get this to someone who can explain to me what is wrong.

Constructive direction would be appreciated.

P.S.

Went to "contact us". Typed the same info. Failed the "security" exercise, then received an email indicating that no one monitors the "contact us" email account. I can hack into your bank account easier than accessing this forum.

RANT OVER

  • Like 1

Share this post


Link to post
Share on other sites

Use a password manager like LastPass.

Share this post


Link to post
Share on other sites

This site and my browser Opera stopped playing nice so I changed to Microsoft edge and no more worries. I was getting verify your not a robot constantly with Opera and just gave up. Not the same I know just saying, I ok Edge to remember login and it makes it much easier FWIW 

Share this post


Link to post
Share on other sites
7 minutes ago, stratoliner92 said:

This site and my browser Opera stopped playing nice so I changed to Microsoft edge and no more worries.

I moved to Firefox years ago and haven't looked back. The only Micro-snert product I use is Win-7Pro...and you'll have to pry that from my cold, dead fingers - yes, I tried Win-10 (shudders).

  • Like 1

Share this post


Link to post
Share on other sites
7 hours ago, MN Fisher said:

I moved to Firefox years ago and haven't looked back. The only Micro-snert product I use is Win-7Pro...and you'll have to pry that from my cold, dead fingers - yes, I tried Win-10 (shudders).

Try it with classic shell and set to win 7 style. You're welcome.

Share this post


Link to post
Share on other sites
51 minutes ago, FishDewd said:

Try it with classic shell and set to win 7 style. You're welcome.

It's not just the 'new' interface that riles me...it's that you can't pick and choose what updates to apply. I want control of my system...I don't want someone telling me what I need and don't need.

Share this post


Link to post
Share on other sites

Share this post


Link to post
Share on other sites

Turn private browsing off?

Share this post


Link to post
Share on other sites

As suggested in the response you received via email, please delete your cookies and cache, restart your browser, and try again.

 

That said, you haven't provided the browser you're using, OS, and platform (mobile/desktop).

 

I suggest Google Chrome for best experience.

Share this post


Link to post
Share on other sites
9 hours ago, MN Fisher said:

It's not just the 'new' interface that riles me...it's that you can't pick and choose what updates to apply. I want control of my system...I don't want someone telling me what I need and don't need.

Ah yes, of course. That is a bit frustrating. I think there is a way to see what's being updated and stop it, if not, then you can definitely remove installed updates via pc settings. One thing that helps is to set the updates so that it won't download updates not for windows. Like mine only downloads relevant things related to security, drivers, etc. Doesn't run for everything like I've had to deselect on other versions. Just a lil different... my main gripe was the interface. ALl in all it isn't bad, just gotta get through the annoying hidden things lol.

Share this post


Link to post
Share on other sites

I use chrome. I can go a week or two, sometimes more, without coming here and I'm always still logged on. It's gotta be something on your end. Trouble shooting these types of problems can be a pain though, good luck

Share this post


Link to post
Share on other sites
23 hours ago, FishDewd said:

Hm I guess Nitro decided to give up and not give a follow up...

....Or he just can't log back in. 

Share this post


Link to post
Share on other sites
20 minutes ago, kenmitch said:

....Or he just can't log back in. 

Lol fair point.

 

Actually, I 'm pretty sure I had this exact same issue way back when... and what solved it for me was clearing cache/cookies. Hate to see someone call it quits over a silly machine like a computer not behaving. :punch:

Share this post


Link to post
Share on other sites

Maybe  he went fishing.

  • Haha 1

Share this post


Link to post
Share on other sites

Some of us old timers are just challenged by the technology!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • fishing forum

    fishing

    fishing rods

    fishing reels

    fishing forum

    fishing

    bass fish

    fish for bass
    fish

×