Jump to content

Recommended Posts

I bought a Curado DC. I have been playing with this thing for 5 days and cannot get it to work. I've cleared more backlashes in the past 5 days than I have in the past 5 years. 

 

I followed the instructions regarding the spool tension adjustment. I have made adjustments according to the instructions and both tighter and looser than the instructions. 

 

It backlashes in 1, 2, 3 and 4 settings. If I lob it in #4 the spool usually but not always stops without an overrun (when adjusted according to the instructions). If I try an overhand cast or use my wrist it backlashes in any setting. I have yet to make a cast in 3, 2 or 1 w/o a major backlash. BTW it is spooled with braid. 

 

I cannot hear the noise it is supposed to make when casting but I have trouble hearing high frequencies. It may be there I just don't hear it.

 

I'm even having trouble thumbing the spool. I have been using bait casters for 50 years but this one has me beat for now. 

 

Have any of you guys had a similar problem? How did you fix it? 

 

Has anyone received a bad reel from the factory?

 

Any advice would be appreciated.

 

Thanks

Share this post


Link to post
Share on other sites

I got my Curado a couple of weeks ago and have only fished with it once but I haven’t had any problems with it. I have it spooled with braid and a Mono leader and have it set so that the spool barely moves side to side. Running it on the braid setting it casts a 1/2 oz jig a country mile with zero backlash.

 

Maybe you got a defective unit, try reaching out to Shimano USA and see what they say.

Share this post


Link to post
Share on other sites

I havnt been able to fish mine yet but I litteraly cast it into a wall without a back lash. 

Share this post


Link to post
Share on other sites

Set the spool tension to where if you drop the lure straight to the ground it doesn't backlash, then give it another half turn tighter. Does it still overrun that way on setting 4? If so it seems like you have a defective DC unit.

Share this post


Link to post
Share on other sites

I have no experience with that reel, but have read several posts about it.  Something must be wrong with that particular reel.  It happens.  My first reel with an SV spool had problems, but was good after a trip to a well know Daiwa tuner.  In your case I'd be getting in touch with Shimano.  My only DC experience is with an older Exsence.  As long as I don't go below Maximum on the brake setting it doesn't require a thumb.  No thumb needed on any of the other settings....SP, BB or F.

Share this post


Link to post
Share on other sites
1 hour ago, Junger said:

Set the spool tension to where if you drop the lure straight to the ground it doesn't backlash, then give it another half turn tighter. Does it still overrun that way on setting 4? If so it seems like you have a defective DC unit.

I tried it tight with no backlash when it dropped and normal and still had backlash when I cast.

 

I'm beginning to think it might be defective. I think I tried almost every possible combination and did not find the sweet spot.

 

Thanks for your help guys. I will call Shimano tomorrow.

Share this post


Link to post
Share on other sites

If Shimano won't help, I will give you $150 for it.

  • Haha 2

Share this post


Link to post
Share on other sites

I just purchased a Curado DC and have not had any issues yet but I have only just tossed it around a pond that just thawed.  

 

I have seen this on a Calcutta DC reel though and it was a simple fix.....  The guy I saw with this issue fought it for about a month and was ready to return it or ship it to Shimano for repair.  He called Shimano and they had him pull all of the line off of the spool and re-spool it.  Problem solved.  The knot he had tied onto the spool had come loose and the line was slipping and was sloppy, this would stop the DC cast control from functioning properly.  

Share this post


Link to post
Share on other sites

One other thing......  If I read the instructions correctly, it is possible to over tighten the cast control knob causing the DC function not to work.  The instructions word it like this ....."If the cast control knob is tightened more than necessary, the DC System can not demonstrate its original performance."

Share this post


Link to post
Share on other sites

Fish Tank

 

I will try that because a couple of times I thought the pool was turning and the line was slipping. 

 

Thanks

1 hour ago, jbsoonerfan said:

If Shimano won't help, I will give you $150 for it.

I'm not that desperate ….yet!!

  • Haha 1

Share this post


Link to post
Share on other sites
5 hours ago, FishTank said:

I have seen this on a Calcutta DC reel though and it was a simple fix.....  The guy I saw with this issue fought it for about a month and was ready to return it or ship it to Shimano for repair.  He called Shimano and they had him pull all of the line off of the spool and re-spool it.  Problem solved.  The knot he had tied onto the spool had come loose and the line was slipping and was sloppy, this would stop the DC cast control from functioning properly.  

That was my problem with my curado dc, I ended up having to put tape over knot to keep it from slipping. 

Share this post


Link to post
Share on other sites
7 hours ago, matbellon3 said:

That was my problem with my curado dc, I ended up having to put tape over knot to keep it from slipping. 

Thanks!! I'm on my way out to try it now.

Share this post


Link to post
Share on other sites

Well, He’s either picking out a backlash or casting out into the snow with a smile on his face. 

Share this post


Link to post
Share on other sites

Picking out a backlash. It didn't work. I respooled and taped the line. Then I respooled over mono and it still didn't work.

 

I called Shimano and I will be sending it in for them to look at.

 

Guys thanks for all your help and advice.

 

 

Share this post


Link to post
Share on other sites

Fingers crossed they get you squared away and make it right for you. I think your patience and approach to looking for help here without bashing Shimano was admirable, as was your transparency about contacting them. 

Share this post


Link to post
Share on other sites
5 hours ago, Dogface said:

Picking out a backlash. It didn't work. I respooled and taped the line. Then I respooled over mono and it still didn't work.

 

I called Shimano and I will be sending it in for them to look at.

 

Guys thanks for all your help and advice.

 

 

Cant you just return/exchange the one you have to where you bought it? I wouldnt ship a defective product to the company, on my dime, during the return period.  

Share this post


Link to post
Share on other sites
1 hour ago, QUAKEnSHAKE said:

Cant you just return/exchange the one you have to where you bought it? I wouldnt ship a defective product to the company, on my dime, during the return period.  

I considered that but figured Shimano was going to end up with it in the end.

 

It is packed and ready to go. I just hope the turn around time is not excessive. The weather here is starting to break and I wanted to get out and play with my new toy. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • fishing forum

    fishing

    fishing forum

    fishing rods

    fishing poles

    fishing

    fishing reels

    fishing poles

    fishing reels

    fishing

    fishing

    bass fish

    fish for bass
    fish

×