Jump to content

Recommended Posts

I've got an 85 Yammie 115hp (115ETLK) thst runs very very nicely so far. My only issue is that it smokes quite a bit. I'm using Mercury 2cycle oil at 50:1 and can't really think of any other issues. Any ideas?

Link to comment
Share on other sites

IF you are premixing it will smoke. An engine only requires 50:1 at full throttle. At idle an oil injected engine is getting more like 100:1 and it goes up as the rpms go up. More rpms more oil. Too bad theres no other way to adjust your oil but 50:1 is the only safe way to premix. If it is still smoking at full throttle then I would guess you may have more serious problems, but lets hope not!!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.



  • Outboard Engine

    fishing forum


    Outboard Engine

    Outboard Engine

    fishing tackle

    fishing

    fishing

    fishing

    fishing

    bass fish

    fish for bass



×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.