Jump to content
Sign in to follow this  
quanjig

Tohatsu 18Hp 2 Stroke Question

Recommended Posts

Was running my jonny around the res and while at wot, started loosing power and had some surge/fade issues. Water pump is pumping, idles and starts first pull, just totally lost top end! Any suggestions on things to look at or try before I call my mechanic? Money is tight and I am somewhat mechanically inclined. I have a buddy with a service manual and can always look at that but you guys have always been helpful so I decided to look here first.

Thanks

Share this post


Link to post
Share on other sites

I would look at my fuel pickup/delivery system first. My first test would be, when it's doing it, try squeezing the primer bulb and keeping pressure on it and see if runs better. Also, pull the cover off and pump the bulb up firm to check for leaks. Anyway, it's sounds like it's either sucking air, the carburator dirty/needle sticking, a restriction in the fuel line, like a dirty filter or something or the fuel pump is not doing it's thing.

Share this post


Link to post
Share on other sites

Thanks for the things to check. Just had the fuel pump rebuilt last fall, carb pulled apart and checked last fall, tried the primer ball trick while running on Sunday. I will check the other things you mentioned as well as new plugs this week. Fortunately, my fishing partner has a boat for the tx this Sunday!

Share this post


Link to post
Share on other sites

W2slow is right, IMO, start w/ the fuel delivery system. New fuel line and primer bulb, both designed to handle gas w/ethanol, is a cheap and easy replacement. Some of the pics of degraded fuel lines and bulbs, posted on other Mercury boards, convinced me to do it this winter. I'm surprised at the difference: easier starts, better idle, etc. The interior of my old lines and bulb had some degradation when I opened them up.

That degraded crap ends up in your fuel filter, carb, etc.

I think someone posted some pics of degraded line on this board also.

Jon, I can send you the info where I got the new ethanol-approved parts, and I have some leftover fuel line (maybe even some hose clamps) from my project, lemme know.

**** Use fuel hose clamps for the connections! Not cable ties! Previous owner used cable ties on my setup: not good!****

Share this post


Link to post
Share on other sites

Thanks Mike, let me know about where you found the ethanol approve lines and bulb and I always use clamps!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • fishing

    fishing forum

    fishing rods

    fishing reels

    fishing

    bass fish

    fish for bass
    fish

×