Jump to content
Sign in to follow this  
JeziHogg

Another Gen3 Revo Winch Problem... Again

Recommended Posts

So now one of my winches has another problem. I usually have two of the 6 centrifugal brakes engaged and the mag brakes are completely off. Now when I cast, about half way into the cast I hear a squeak and one or two random centrifugal brakes will just engage on there own. My spool shaft pin is bent, would that have any effect on it?

Share this post


Link to post
Share on other sites

So now one of my winches has another problem. I usually have two of the 6 centrifugal brakes engaged and the mag brakes are completely off. Now when I cast, about half way into the cast I hear a squeak and one or two random centrifugal brakes will just engage on there own. My spool shaft pin is bent, would that have any effect on it?

My non professional guess would be yes. Think of it like this. That sucker is spinning like greased lighting. Like a car tire so to speak. Anything off balance or out of whack is going to cause vibrations and jiggle things loose.

How did the spool shaft get bent? The new winch's use the STX style short shaft spoon don't they?

Share this post


Link to post
Share on other sites

The shaft is fine, its just the spool shaft pin is slightly bent. I tried taking it out using a "home made tool". I ordered the Boca Bearing tool and replacement pins... just waiting now for it to come in the mail.

 

And no, the spool shaft goes all the way through to the tension cap.

Share this post


Link to post
Share on other sites

So now one of my winches has another problem. I usually have two of the 6 centrifugal brakes engaged and the mag brakes are completely off. Now when I cast, about half way into the cast I hear a squeak and one or two random centrifugal brakes will just engage on there own. My spool shaft pin is bent, would that have any effect on it?

 

The brake shoes engaging randomly should have nothing to do with the bent spool pin.  There's something wrong inside the brake retainer on the spool assembly.

Share this post


Link to post
Share on other sites

The brake shoes engaging randomly should have nothing to do with the bent spool pin.  There's something wrong inside the brake retainer on the spool assembly.

I took the retainer off to see how the brake shoes work, all it is was 6 orange plastic brake shoes with notches sticking out each side that clip into a plastic housing with 2 positions for the notches to sit in, as well as the springs that go inside the brake shoes, they all looked the same with no wear.

 

But I think I solved the problem, I just took out 4 of the 6 shoes and springs and put the retainer cap back onto it and whamo no problems.

Talk about back yard mechanics lol

Share this post


Link to post
Share on other sites

I took the retainer off to see how the brake shoes work, all it is was 6 orange plastic brake shoes with notches sticking out each side that clip into a plastic housing with 2 positions for the notches to sit in, as well as the springs that go inside the brake shoes, they all looked the same with no wear.

 

But I think I solved the problem, I just took out 4 of the 6 shoes and springs and put the retainer cap back onto it and whamo no problems.

Talk about back yard mechanics lol

 

Nice fix!

Share this post


Link to post
Share on other sites

The shaft is fine, its just the spool shaft pin is slightly bent. I tried taking it out using a "home made tool". I ordered the Boca Bearing tool and replacement pins... just waiting now for it to come in the mail.

 

And no, the spool shaft goes all the way through to the tension cap.

my mistake. I read that wrong. I had never taken the new Winch reels apart. I thought they had the same spool design as the STX's

Share this post


Link to post
Share on other sites

 Either way, I fell for the new Revo marketing hype and now I will never buy an Abu product ever again.

 

lol edited out the spelling, its getting late

Share this post


Link to post
Share on other sites

Me either way, I feel for the new Revo marketing hype and now I will never buy an Abu product ever again.

 

I fell in love with them like a school girl after icast last year. I dumped everying I had for them and spent the better part of the year switching and mad as hell

Share this post


Link to post
Share on other sites

So now one of my winches has another problem. I usually have two of the 6 centrifugal brakes engaged and the mag brakes are completely off. Now when I cast, about half way into the cast I hear a squeak and one or two random centrifugal brakes will just engage on there own. My spool shaft pin is bent, would that have any effect on it?

This is happening to one of my Gen3 STX's.... I'm not buying any more Revos.

Share this post


Link to post
Share on other sites

Abu really pooped the bed on the new revo.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • fishing forum

    fishing

    fishing forum

    fishing rods

    fishing poles

    fishing

    fishing reels

    fishing poles

    fishing

    fishing

    bass fish

    fish for bass
    fish

×
×
  • Create New...