Jump to content
Sign in to follow this  
dam0007

Live Target Ratltrap Issue?

Recommended Posts

Got one of these via one of the subscription services, first cast with it had a follow and a light hit I missed at the boat. Few casts later got stuck in some rip rap, after that the thing wouldn't swim right. Like you would have to yank real hard to get the wiggle going. I've had tons of lures get stuck and loosened and unless it broke it still wiggled right. Any of you guys experience this with these? I like the light rattle sound would be good for a few places up here.

Share this post


Link to post
Share on other sites

Did the hook get "all bent outta' shape"? If there isn't enough resistance from the hooks, it will not wiggle properly or as much.

nope hooks didn't get stuck or deformed in anyway. The nose is lightly chipped.

Share this post


Link to post
Share on other sites

A chip in the nose shouldn't effect it that much. I don't use that brand, but my Aruku Shads and Xcaluburs get beat up to where the paint is gone and they still work great.

Share this post


Link to post
Share on other sites

Got one of these via one of the subscription services, first cast with it had a follow and a light hit I missed at the boat. Few casts later got stuck in some rip rap, after that the thing wouldn't swim right. Like you would have to yank real hard to get the wiggle going. I've had tons of lures get stuck and loosened and unless it broke it still wiggled right. Any of you guys experience this with these? I like the light rattle sound would be good for a few places up here.

What one do you have?

Share this post


Link to post
Share on other sites

check to see if the chip has cracked it and if it is filling with water. livetarget is my favorite lipless crank. have several that have no paint or eyes left and they still catch fish

Share this post


Link to post
Share on other sites

I'm at a loss here, I've never had a bait literally stop working unless it was completely destroyed. Just the golden black color on nose is chipped a bi. No cracks. Re verified that tonight, it's not filling with water.

Share this post


Link to post
Share on other sites

Send it back to Koppers. They will replace it for free. I had a problem with a blue back herring swimbait and they replaced it no questions asked.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • fishing forum

    fishing

    fishing rods

    fishing reels

    fishing forum

    fishing

    bass fish

    fish for bass
    fish

×