Jump to content

Recommended Posts

Has anyone had issues with installing power pole on a aluminum

Bass boat. I have a Ranger Rt178 with 70 hp Zuzuki.

Since power pole has been installed I am having porpoising

Issues. It feels like to much weight in the rear of boat. I had dealer move

Engine up one notch. Has improved but still having issues.

If anyone has had some of these same issues I would appreciate

Your input.

Thanks

Share this post


Link to post
Share on other sites

Can the porpoising be eliminated or minimized using the trim? You may have to redistribute weight in your boat too and move some heavier stuff up front. 

Share this post


Link to post
Share on other sites

What model of power pole did you instal? Did you instal 1 or 2?

Share this post


Link to post
Share on other sites

I went with the Micro power pole on my 2014 RT178.  Holds the boat in heavy wind and waves. Great addition. 

Share this post


Link to post
Share on other sites

I have an Xpress h20 and I had similar issues. I Redistributed weight and adjusted the trim and mine works fine. Hopefully that works for you. -Tight lines man.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • fishing

    fishing forum

    fishing rods

    fishing reels

    fishing

    bass fish

    fish for bass
    fish

×