Jump to content
semaj81

Lew's Laser MG LSG1HMG Will Not Reel In?

Recommended Posts

New to the forums and I'm stumped!! I just bought a combo set with Lew's Laser MG LSG1HMG reel and I'm having a pretty rough time! It's been years since I've touched a baitcast reel and am genuinely stumped if there's a problem with the reel, or me. It spins just fine, will reel in great. Cast release jumps back into place each time. Now here's the issue if I can explain it properly.

 

I was trying to put some line on (non-braided) and noticed with the slightest bit of resistance, the main champer stopped spinning while trying to reel it in. I am lost as to what the issue is. If I reel with no line, and nothing touching the main roller (where the line winds?) it spins fast and free. The slightest touch? It stops spinning, yet you can keep on reeling until you decide to stop. Is the drag too loose? I have done nothing with this thing other than buy, bring home, and sat until I bought some line to put on.. It just won't reel if there's any force at all....

Share this post


Link to post
Share on other sites

I have never heard if such a problem like this so I'm not sure I can be of any use but here goes.

 

Try setting your drag to max if it still doesn't work best bet would be to bring it back for a replacement.

 

I have one sitting next to me right now I will turn the drag all the way down and see what it does. 

 

Stand bye.

Share this post


Link to post
Share on other sites
4 minutes ago, A5BLASTER said:

I have never heard if such a problem like this so I'm not sure I can be of any use but here goes.

 

Try setting your drag to max if it still doesn't work best bet would be to bring it back for a replacement.

 

I have one sitting next to me right now I will turn the drag all the way down and see what it does. 

 

Stand bye.

Nice.. I hate to sound totally clueless but it has been a long time.. the drag is the knob here on the right by the main reel? And the other dial on the left is for the break?

Share this post


Link to post
Share on other sites

Yep the drag is the star looking knob behind the crank. The little turn knob next to it is for your spool speed control. And the break setting is on the left side of the reel.

 

You could try setting all three of these to max and see what it does.

 

Also how is the line tied on is it tight around the spool are is it kind of loose on the spool?

 

You want the line tied tight to the very center of the spool and try to set the lil string guide so it lines up dead center with the center of the spool. That's what I do and it seems to help make the line lay down on the spool better when I respool my reels.

 

But to be honest I think there is something wrong with that reel, I just finished trying one of mine and I turned the drag,breaks and spool speed to full off and it still picked up line, so I reset the reel tohow it was and tryed it again and it picked the line up fine.

 

I would return it and get a replacement I think it's broke sir.

 

Share this post


Link to post
Share on other sites
3 minutes ago, A5BLASTER said:

Yep the drag is the star looking knob behind the crank. The little turn knob next to it is for your spool speed control. And the break setting is on the left side of the reel.

 

You could try setting all three of these to max and see what it does.

 

Also how is the line tied on is it tight around the spool are is it kind of loose on the spool?

 

You want the line tied tight to the very center of the spool and try to set the lil string guide so it lines up dead center with the center of the spool. That's what I do and it seems to help make the line lay down on the spool better when I respool my reels.

 

But to be honest I think there is something wrong with that reel, I just finished trying one of mine and I turned the drag,breaks and spool speed to full off and it still picked up line, so I reset the reel tohow it was and tryed it again and it picked the line up fine.

 

I would return it and get a replacement I think it's broke sir.

 

OMG... I'm such an idiot. It was the drag! I completely forgot that was the drag setting!!! It's all good now!! Amazing, thank you!!!

  • Like 2

Share this post


Link to post
Share on other sites

No problem glad I could help sir.

Share this post


Link to post
Share on other sites
16 minutes ago, A5BLASTER said:

No problem glad I could help sir.

It's just been so long it didn't even hit me that the drag was open all the way.. First baitcast reel in probably 20 years.. Thanks again!

Share this post


Link to post
Share on other sites

No problem sir, that's what this fourm is for folks helping other folks.

Share this post


Link to post
Share on other sites

I've had this happen.  Not sure how, but my reel wouldnt reel and I discovered my drag was off.  As in loosened all the way. 

  • Like 1

Share this post


Link to post
Share on other sites

My lews is the same way, if you back the drag all the way off it won't always spin the spool. 

Share this post


Link to post
Share on other sites
8 hours ago, frosty said:

My lews is the same way, if you back the drag all the way off it won't always spin the spool. 

 

Mines also a Lews Speed Spool.  

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • fishing

    fishing forum

    fishing rods

    fishing reels

    fishing

    bass fish

    fish for bass
    fish

×