Jump to content
Sign in to follow this  
92 5 oh

Merc OB stalls when giving it the gas

Recommended Posts

The other day i was out and went WOT once for about 20 seconds.  a few seconds after that the boat started stalling any time i gave it anything more than idle.  even at idle it wasn't all there but i could limp back to the dock.  it doesn't vibrate real bad or anything or feel like misfire and i don't hear any odd or 'bad' noise.  if I don't put it in gear and just give it gas, it'll rev up ( i didn't go higher than about 3500), and feels like it'll rev a little higher but it still feels like it's missing power.  i did notice that if i squeeze the primer bulb the power comes back and it feels like it should. so i suspect the problem is in the fuel delivery. the first thing i checked was the tank, the vent was open.  i also noticed that primer bulb is harder than normal to squeeze, regardless if the fuel filter is empty.  so actually i think the problem is within the hose or primer.  anyone ever has this kind of problem before? or have any suggestions? by the way this is a 2001 25hp mercury OB 2 stroke

thanks

steve

Share this post


Link to post
Share on other sites

It is a fuel delivery problem. Start with the inline filter and check to see if there is a filter mounted on the motor. this is probably going to be your problem. then go with a new bulb and fuel line hose. I'm not sure if that model has the filter up on the motor, I deal only  with the V-6. I bet it does and it is usually the one that gets missed. Good luck.

Share this post


Link to post
Share on other sites

I had a similar problem and mine turned out to be a combination of fouled plugse and air trapped in the fuel lines in the motor next to the carbs.  My Evinrude has a bleeder valve and I got the air out and it runs fine now.

Share this post


Link to post
Share on other sites

replace the whole fuel line including the bulb.

Share this post


Link to post
Share on other sites

Yes, I had the same problem replaced the bulb and line, didn't fix it.

I replaced the fuel pump gasket in the carb, runs great now. The whole kit was 35 bucks so I replaced all the gaskets.

so it could also be the fuel pump built into your carb,  raise your can over the motor and run it (in the driveway of course) see if your problem goes away.  

Share this post


Link to post
Share on other sites

cool deal. thanks for the suggestions. It does have a fuel filter on it, the strainer isn't clogged and there aren't any air pockets visible when i pump the bulb.  tomorrow i'm hoping to replace the bulb/fuel line. I'm also going to replace the plugs while in there.  i haven't seen a bleeder valve but i'll double check.  i'll see what happens soon!

thanks

steve

Share this post


Link to post
Share on other sites
Yes, I had the same problem replaced the bulb and line, didn't fix it.

I replaced the fuel pump gasket in the carb, runs great now. The whole kit was 35 bucks so I replaced all the gaskets.

so it could also be the fuel pump built into your carb, raise your can over the motor and run it (in the driveway of course) see if your problem goes away.

Mayassa, what motor did/do you have?

Share this post


Link to post
Share on other sites

mariner  20hp 2 stroke been working carb since I was 12, 2 strokes and 4 strokes on dirtbikes and my hogs.  Pretty easy to rebuild just take it slow and call me if you need to talk.  IM me for my number.

Share this post


Link to post
Share on other sites

Cool thanks for the help!  i've done some 2 stroke work before. small things though, like lawmowers, weed eaters, RC cars.  I've been so busy lately with work at everything else I haven't had time to work on it yet. i'm hoping that i can work on it this weekend.  

Thanks again, I'll PM you if I run into a problem.

steve

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • fishing forum

    fishing

    fishing rods

    fishing reels

    fishing forum

    fishing

    bass fish

    fish for bass
    fish

×