Jump to content
Sign in to follow this  
mames19

Trolling Motor Not Spinning

Recommended Posts

i had my trolling motor checked over by a service center and they found nothing wrong with it, then i hooked it back up on my boat and it does nothing. i have 25 volts at the inlet to the motor, when the pedal is pushed it goes to 2 to 3 volts, then when depressed it goes back to 25 volts. tested at the batteries they hold at 12.4 volts each with the trolling motor running, any ideas?

Share this post


Link to post
Share on other sites

The batteries feed voltage to the foot pedal, which in turn, feeds voltage to the TM. If the batteries are good and the TM is good, then the problem is between the two. If the voltage coming in to your pedal is good, then It's the pedal circuitry that is your problem. Make sure that ALL of your connections are free of corrosion, including those coming into and out of the pedal.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • fishing

    fishing forum

    fishing rods

    fishing poles

    fishing

    fishing poles

    fishing poles

    fishing reels

    fishing

    fishing

    bass fish

    fish for bass
    fish

×
×
  • Create New...