Jump to content
Sign in to follow this  
cddan

Curado 300e

Recommended Posts

My shimano curado 300e is a very good reel.  Problem though is with braid it winds the line high in the middle not evenly across.  With mono it's perfect.  

Using 30 and 50 lb power pro. Do I need better braid or is it the nature of thos higher capacity reel. 

Share this post


Link to post
Share on other sites

It;s not the nature of the high capacity reel or the braid that your using. Is it getting so bad in the middle, the braid is hitting the frame?

Did you over fill it with braid?

Pic would help...

Share this post


Link to post
Share on other sites

 Usually about half full(when spooling)  I notice it beginning to mound in the middle.  I have no pic because I have just been using mono or backing with half mono then braid to get better lay from the braid. I really wanted to run a full spool of braid but cannot.  

Share this post


Link to post
Share on other sites

Fill it up with braid and go use it on the water...Bet your problem will be solved.

Or go to the park and tie to a tree, let out as much line as you can. When you reel in make sure you have plenty of tention and, aim the rod tip at the tree.

Share this post


Link to post
Share on other sites

is your connection to backing knot too large and in the middle?

  • Like 1

Share this post


Link to post
Share on other sites

I have fished with it with the braid on it stayed the same.  I have taped the line on before spooling to avoid a large knot and spooled under very tight tension. Oddly if I use mono there's no problem.  I'll try it all again using the suggestions maybe I overlooked something but I have tried several times 

The reel is awesome with mono does anyone have a 300e and braid brand suggestion? 

Share this post


Link to post
Share on other sites

good suggestion/question from iabass about the connecting knot.  i've had that happen before and would make the line do some weird stuff on the spool.

Share this post


Link to post
Share on other sites

I did fool around with the connecting knot.  I put it to one side instead of the middle and tied a small knot. Spooled the line with adequate tension.

This worked thank you everyone  

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • fishing

    fishing forum

    fishing rods

    fishing reels

    fishing

    bass fish

    fish for bass
    fish

×