Jump to content
Sign in to follow this  
GeologyRocks

Revo S Spool Tensioner help/troubleshooting

Recommended Posts

All - I have an older gen Revo S that's having trouble with the spool tension dial. It screws on just fine, but has no "clicks" and goes from freely screwing on to dead tight in about a quarter of a turn. When it's tightened all the way down it doesn't slow the spool or bait from falling.

I took the dial off and there's a small black hard plastic washer with a very thin metal disc underneath that has a few notches. I'm not sure how these are supposed to layer or which way they're supposed to face but I tried all combinations with no dice.

 

Any tips? Thanks ahead of time!

Share this post


Link to post
Share on other sites

Check a schematic to be sure all the parts are there. Inside the cap should be a flat rubber spacer, a black plastic click washer, a small carbon spacer in the middle, and a metal spring washer. There's another click washer with short legs that sits in the frame. If it's all there and doesn't click flip the metal spring washer over. Verify via schematic as I'm out and going by memory. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • fishing

    fishing forum

    fishing rods

    fishing reels

    fishing

    bass fish

    fish for bass
    fish

×