Jump to content
stk44

**Assistance Needed ** Curado 70 XG

Recommended Posts

Hi all,

 

I cleaned all of my BC's and Spinning reels over the past few weeks and saved the Curado 70 for last since it is my newest reel. It disassembled fine, but after doing a deep clean and reassembling, it makes a slipping noise, but definitely not a grinding like gears or anything like that.

 

The first thing that threw me off was that the anti-reverse bearing has no recess, or lip that the ARB slides into like my Curado I or any of my abu Garcia LP's. I realized this after popping the ARB out and didn't take a picture beforehand because I thought it would be like all the others. I soaked the ARB in simple green and then, after drying, added 2 drops of oil and went over the ARB with a q-tip. I definitely know that I put the ARB facing the right direction, but I experimented with different seating depths of the ARB and had no luck in solving the problem. 

 

One other variable is that I cleaned the spool tension bearings with acetone and once rinsed and fully dried, I added 1 drop of oil to each, which I also have done with my Curado I and Abu's without any issues. After reassembling and disassembling dozens of times, I took to youtube and watched a video about the Curado 70 reassembly, and the guy mentioned that you should never put any oil in either of the (2) spool tension bearings unless absolutely necessary. Is this true??

 

 

I believe the issue is with the ARB, but it could be a number of things:

 

-too much/too little oil on the ARB 

-improper seating of the ARB (although I think I checked just about every seating depth of the dang thing)

-too much oil/ the presence of oil on the spool tension bearings

 

Can anyone help me figure this one out?

 

Share this post


Link to post
Share on other sites

What is a slipping noise? Is it actually slipping? I'll be happy to have a look if you need. 

Share this post


Link to post
Share on other sites

DVT, it’s hard to explain. It doesn’t sound like metal on metal grinding (clicking may be a better term.)  It seems like it’s something slipping because the noise can be heard briefly at the end of every crank of the reel handle ( as long as you aren’t slow cranking.)

I put a request in to Shimano, so I’ll see what they can do since the reel is only 6 months old. It’s weird that I’ve cleaned my Revos and curado I’s the same way and haven’t had issues. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • fishing

    bass fishing

    fishing forum

    fishing rods

    fishing rods

    fishing rods


    fishing rods

    fishing reels
    fishing gear

    Truck Caps

    fishing reels
    fishing reels

    fishing

    bass fish

    fish for bass
    fish

×