Jump to content
Sign in to follow this  
Splat

Tell Tale on 1995 25HP Merc

Recommended Posts

Hey guys.

I just bought a new (to me) boat. It has a 25 Merc outboard on it. As I'm aware the unit has a thermostat on it. I'm totally new to this outboard thing.

Now my question. I've only ran the engine with ears on it hooked to the garden house. When you initially start the engine up there is a little hole above the prop on the starboard side that begins to pee water. The hole is very low (just below the Stabilizer) and will almost certainly be below the water line. After the engine warms up the water begins to flow from a tube located just behind the tiller handle. This water is very warm and the flow starts and stops normally( thermostat cycling) from this hole.

My question here is should there also be a hole above the water line that continually flows water to let you know the water pump is working? I know Currently I have pressure because of the thermostat cycling, but I want to make sure it's working normally before I take it to the lake and put it in water and have it suck water, instead of having city pressure forcing it.

Do I just have to wait for it to warm up and expel water from that upper hole to make sure it working?

I'll add it's a model 1025311r

Bill

Share this post


Link to post
Share on other sites

My mercury has to warm up before it pee's continuously. I thought something with mine was messed up also so I took it in and they told me that it just has to warm up and the thermostat will open. Unsure of indicating the pressure as mine has a pressure guage but if it is peeing you should be good.

Share this post


Link to post
Share on other sites

i think what hes asking is if it is supposed to pee above the water, the answer is yes. its so that you know your water pump is working properly, if the pee is week then you should consider changing the impeller, changing the impeller is normal maintenance...

and yea, its no big deal if its burning hot water thats coming out, its the water that just cooled your blazing hot engine.

Share this post


Link to post
Share on other sites

Hey great guys. Thanks!

I went to get stickers yesterday at a local marine dealer and spoke with them about the motor. They said what you all did, it's normal to only have water coming out of the one hole and only when the thermostat opens.

Bill

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • fishing forum

    fishing

    fishing rods

    fishing reels

    fishing forum

    fishing

    bass fish

    fish for bass
    fish

×