Jump to content
Justbass11

Shimano clicking after cleaning

Recommended Posts

Ok so I cleaned my Shimano Citica, Now it doesn’t want to engage and clicks when I pull on the drag...this might not be so good. Any ideas what could be wrong??? Thanks for your inputs. 

Share this post


Link to post
Share on other sites

Sounds like multiple things are wrong. You likely put the handle assembly/drag stack together improperly to cause the drag issue. And if your clutch isn't working, you definitely did something wrong. I'd find the manual schematic and take it apart again. Or if you're not comfortable, send it to a professional like DVT.

  • Thanks 1

Share this post


Link to post
Share on other sites
3 hours ago, fishballer06 said:

Sounds like multiple things are wrong. You likely put the handle assembly/drag stack together improperly to cause the drag issue. And if your clutch isn't working, you definitely did something wrong. I'd find the manual schematic and take it apart again. Or if you're not comfortable, send it to a professional like DVT.

 

+1

 

 

Share this post


Link to post
Share on other sites

Search you tube for critica or curado I for service and maintenance (give that your citica is the same as curado I). Watch how they do it over and over, you might find the way you did wrong. Make sure to have schematic on hand. Seem like you not set main gear correctly. Did you do anything to worm gear?

  • Thanks 1

Share this post


Link to post
Share on other sites
9 hours ago, fishballer06 said:

Sounds like multiple things are wrong. You likely put the handle assembly/drag stack together improperly to cause the drag issue. And if your clutch isn't working, you definitely did something wrong. I'd find the manual schematic and take it apart again. Or if you're not comfortable, send it to a professional like DVT.

x2

 

It sounds like part of the drag stack may have been put back in the wrong order or "upside down" causing gears to slip, or you may have put the clutch mechanism back in wrong. If you take it back apart find your reel schematic AND a good video on youtube to follow along with so you can see visually what might be wrong (I always found that more easy to check against than my reel schematic). 

  • Thanks 1

Share this post


Link to post
Share on other sites
13 hours ago, Justbass11 said:

Ok so I cleaned my Shimano Citica, Now it doesn’t want to engage and clicks when I pull on the drag...this might not be so good. Any ideas what could be wrong??? Thanks for your inputs. 

Contact me via email or phone and I'll give you the likely cause. 

Mike

  • Thanks 1

Share this post


Link to post
Share on other sites

Thanks Mike and the rest of you guys for your advice, I tried to fix the reel after watching some YouTube videos about the reel and look up the schematic, still not fixed. Anyway Mike sent you an email hope to hear back from you. Thanks again everyone 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • fishing

    fishing forum

    fishing rods

    fishing reels

    fishing

    bass fish

    fish for bass
    fish

×