Jump to content
Sign in to follow this  
LazyBASS1301600404

Curado 201E7 HELP??

Recommended Posts

Was wondering if anyone can help me here.

While I was fishing with this reel I got a bite, went to set the hook and the drag went zzzzzzz and now it doesn't reel, well it reels but it BARELY picks up any line. If I gently thumb it, it won't reel at all. Also I can strip line off the reel(while the drag is tighten to the max) as if it was on free spool? I think I broke it. I opened up the brake system part and the spool comes out with ease, is it supposed to be like this?

Question, do I try to fiddle with it or is there a lifetime on reels as well? Am I SOL? I have the box that it came with but I think thats about it.

HELP!!!   :-/

Share this post


Link to post
Share on other sites

You may want to try the rods and reels subforum.   :)

Share this post


Link to post
Share on other sites
braided line by any chance?

My first thought too...Braid will slip on the spool making it seem like your reel has no drag.

Been there did that on a spinning reel a few years ago....Lesson learned...use some mono backing or tape. ;D

Share this post


Link to post
Share on other sites
do I try to fiddle with it or is there a lifetime on reels as well?
Lazy,

There are no lifetime warranties on reels, they are all limited 1 year. If your reel is at least a year or under old send it in to Shimano for factory warranty work.

If older send it in to the site sponsor.

Am I SOL?
Nope
I can strip line off the reel(while the drag is tighten to the max) as if it was on free spool?

Sounds like you have braided line spooled tight and it broke lose on the spools arbor without a backer.

If no braided line spooled used then send it in for sure......

Good Luck & Tight Lines!

Share this post


Link to post
Share on other sites

I had the same incident with Curado 200E5, I'm using braid with a backing of a yard of mono to prevent it from slipping. It' s a case of sticky drag. It happen when you think you already turn the star drag to the right drag setting and when then suddenly it went free spool while fighting a fish. The sticky drag came off after a strong pull. I adjusted the star drag and it's good again. Drags needs to be replaced w/a new set of dartainuim drags and put enough cals grease to make it smooth. It solves the problem. I heard the same incident happen on Curado 300E7.

Share this post


Link to post
Share on other sites

Its probably the braid/no backer issue.  No reason to send it to Shimano, its user error.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • fishing

    fishing forum

    fishing rods

    fishing reels

    fishing

    bass fish

    fish for bass
    fish

×